DHL services experiencing API issues

Incident Report for nShift - Webshipper

Resolved

DHL is running normally.
Posted Dec 11, 2025 - 13:46 CET

Investigating

DHL is experiencing issues with their API connection.
Posted Dec 11, 2025 - 11:50 CET
This incident affected: External Carrier Status.