Drop point service down
Incident Report for nShift - Webshipper
Postmortem

Our Amazon Webservice ECR repository which holds our build images of all our services, unfortunately, had a rule set up on drop point services to delete images older than 90 days. And drop point service had not been updated for 90 days since this weekend.

Thus the ECS (Which uses these images) had nothing to pull since the old ones were deleted, this, therefore, resulted in no drop point services.

We have now changed the policy rules to only delete if there are more than 5 images instead of 90 days. This will ensure that we will not run into this issue again.

Posted Nov 13, 2022 - 11:05 CET

Resolved
This incident has been resolved.
Posted Nov 13, 2022 - 10:21 CET
Investigating
Unfortunately our drop point service is currently unavailable
Posted Nov 13, 2022 - 10:03 CET