Shopify - Missing Shipping Rates
Incident Report for nShift - Webshipper
Resolved
Reports confirm that all previously missing shipping rates in Shopify checkout are now visible again.

If you do not see your Webshipper rates already, please check that you have enabled Webshipper Rate Provider in your Shopify zones and your Webshipper rates are set to be visible in your Webshipper account.

All temporarily flat rates created in Shopify can be disabled again once you can confirm your Webshipper rates are visible in Checkout.
Posted Dec 07, 2022 - 14:42 CET
Monitoring
Latest update:

After much effort and close dialog with Shopify Partner Support, we have been able to narrow down the issue and be able to create a fix that hopefully will solve all missing Webshipper Shipping rates in Shopify checkout.

We would like your help to check if everything is working as intended with Webshipper rates again in your checkout. You may need to refresh your Shopify zone and connect to Webshipper Rate Provider again inside Shopify. Also if you have set your Webshipper rates as hidden, they will need to be made visible again. Try with one rate first to see if it will appear and if all is working as intended, you can freely add the rest.

We would like a mail to support@webshipper.com if your rates are not working again as intended.
Posted Dec 06, 2022 - 14:31 CET
Update
Latest update:

We are still in close dialog with Shopify Partner Support regarding the issue of "Missing Rates in checkout".
Shopify has requested API logs and we are currently looking into building more extensive logging for Shopify.
However, our API requests match the Shopify documentation and we are therefore currently investigating what may be missing in that documentation together with Shopify.

We are still unable to determine if the current approval process to make Webshipper's app listed in Shopify, is directly related to the issue or not. For now, we will not rule out any possible options.
Posted Nov 28, 2022 - 09:47 CET
Update
More reports have come in to confirm that if you update your existing shipping rates and zones in Shopify, this general issue will apply and all your shipping rates from Webshipper will potentially no longer be displayed in checkout.

If you are already affected by the issue, the only solution is to create flat rates in Shopify and match them to your Webshipper rates.
Please follow this guide on how to proceed with matching/linking orders to Webshipper rates.
https://help.webshipper.com/hc/en-us/articles/360010079357-How-do-I-link-shipping-rates-to-my-orders-
Posted Nov 16, 2022 - 19:45 CET
Update
Updated:
The Webshipper app have been approved by the automated app checker in Shopify. Webshipper is awaiting the final and manuel approval for our app with Shopify.
Posted Nov 15, 2022 - 10:18 CET
Update
Updated:
It seems that the issue may be connected to when there have been made a change/update to rates and/or zones in Shopify. This is, however, unconfirmed.
But still, we recommend being careful with making updates, as what we are seeing is that once there is one update to one zone, it is causing a general error on all existing shipping rates.
Posted Nov 09, 2022 - 10:16 CET
Identified
Dear Shopify user

We are currently receiving reports from customers that shipping rates are no longer been shown in checkout.
In short - we are able to receive API requests from the checkout for shipping rates and we can also confirm that we are sending the rates to checkout as requested. However, something appears to be blocking the actual display of rates in Shopify checkout.

We are currently investigating with Shopify Partner Support why Shopify is not displaying the rates. We consider this issue of the highest priority and will be doing everything we possibly can to find the root cause of the block.

The reports started after the 1st of November when Shopify required all "unlisted" apps to become "Listed".
However, Webshipper has received a continuance until the 1st of December to become "listed"
Unfortunately, while Webshipper is in the process of final app approval with Shopify, we are unable to search up errors and locate any issues related to Shopify. It is likely that all issues will be fixed automatically when Webshipper becomes a "Listed" app. It may also simply just allow us to search for errors again once the app is approved.

For now, the only workaround solution is that you create Shopify flat rates directly in Shopify and then link/match those rates with your current Webshipper rates. For info on how to please see this guide:
https://help.webshipper.com/hc/en-us/articles/360010079357-How-do-I-link-shipping-rates-to-my-orders-

If you need help with creating matches/link from flat rates to Webshipper rates or simply have questions regarding the issue, feel free to reach out to us at support@webshipper.com.

Best regards from
Your Webshipper support team
Steffen, Alex, Rasmus K., Rasmus S., Stine & Ninna
Posted Nov 04, 2022 - 10:00 CET
This incident affected: External Order Channel Status.