PostNord currently has degraded performance

Incident Report for nShift - Webshipper

Resolved

The incident has been resolved - https://apistatus.postnord.com/
Posted May 29, 2026 - 16:15 CEST

Identified

We are currently experiencing slow response times from PostNord's API systems. We have notified PostNord about the issue and they are currently working to resolve the problem. We will update this incident as soon as we receive any news.

https://apistatus.postnord.com/
Posted May 29, 2026 - 14:47 CEST
This incident affected: External Carrier Status.