DAO currently has degraded performance

Incident Report for nShift - Webshipper

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 12:15 CEST

Identified

We are currently experiencing slow response times and errors from DAO's IT systems. This can result in errors on shipment creation, label generation and updating tracking information.
We will update this incident as soon as we receive any news.
Posted Jun 24, 2026 - 09:37 CEST
This incident affected: External Carrier Status.